Feisty + Beryl

Questo è un post tecnico di 10 anni fa. Le istruzioni potrebbero non essere più valide.

Ecco a voi Beryl che viaggia alla velocità della luce su Feisty:

Ooops, scusate, ma le foto mi vengono tutte mosse... ;)
Ooops, scusate, ma le foto mi vengono tutte mosse… ;)

Se ancora non lo sapete, i repo per installare Beryl & Co. sono stati aggiunti in Universe. Questo significa che non dovete aggiungere nulla nel vostro sources.list. Basta aprire Synaptic e installarlo da lì, oppure da terminale (più facilmente):

sudo apt-get install beryl beryl-manager beryl-plugins-unsupported emerald-themes

Poi aprite il gestore delle Sessioni (Sistema / Preferenze / Sessioni) e nella scheda Programmi d’avvio create una nuova voce scrivendo questo comando:

/usr/bin/beryl-manager

e dandogli il nome che volete (ad es., Il manager di Beryl).
Uscite dalla sessione e riloggatevi. Dal diamante rosso in alto vicino all’orologio scegliete come Gestore di finestre il vostro fiammante Beryl.

Nella mia macchina, oggi equipaggiata con una nVidia e con i driver restricted, Beryl schizza come un proiettile, molto diversamente da Compiz, che risulta impacciato. Non voglio dare la colpa a Compiz, magari sono io che non riesco a sistemarlo a dovere; fatto sta che Beryl, installato e avviato (senza modificare nulla), è velocissimo. Si conferma, dunque, quanto avevo scritto tempo fa, quando avevo addirittura una scheda diversa dalla attuale. Che dire?, Viva Beryl! :D

Autore: Aldo Latino

Aldo Latino usa con entusiasmo Linux nella distribuzione Ubuntu, è un appassionato di WordPress e si diletta a fare il blogger. Ha anche una lista dei desideri. Per altre informazioni visita la sua .

39 pensieri riguardo “Feisty + Beryl”

  1. confermo. a me compiz va proprio lento(se parte…). poco configurabile. niente. non riesco a farmelo piacere. con beryl mai nessun problema.

    forse sono uno dei pochi che non ha gradito la fusione?

  2. io ho sia beryl che compiz e vanno benissimo tutti e 2 molto veloci anzi forse compiz è anche piu stabile pero purtroppo ha delle funzioni in meno rispetto a beryl (che preferisco).
    A differenza di te pero ho una ati e non ho installato nulla dei repository ma è rimasto dall’aggiornamento dalla edgy!

  3. Anche io sono passato a Beryl , Compiz sta un po stretto se si vuole fare invidia ^_^

    c’è da dire però che per l’utente non molto smaliziato compiz rimane un po meno disorientante, cmq spero che il binomio compiz+beryl sia a favore di quest’ultimo

  4. A me purtroppo lascia un bel desktop bianco una volta abilitato…
    strano perchè prima dell’aggiornamento a Feisty andava benissimo :\

  5. @Maelstrom
    il cubo bianco è dovuto al fatto che probabilmente usi beryl con xgl;
    il bug da tempo conosciuto e stato risolto nel ultima versione git di beryl

  6. E’ bellissimo il cubo, volevo sapere come fare a installare Beryl senza internet? si può ? grazie

  7. Senza Internet? Quantomeno il collegamento al Web ti serve per scaricarti un archivio con l’installer. Fammi sapere di più. :)

  8. scusate ragazzi… una cosa su questo cubo.
    Lo ho abilitato su Feisty, ma io non uso le aree di lavoro: c’è modo di usare le sei faccie del cubo per visualizzare altrettante finestre/applicazioni in uso nell’unica area di lavoro attiva?

  9. ciao aldo io sto usando feisty con beryl(non la versione dei repo) con fglrx… ma adesso riabilitando i repo di universe ho sempre la notifica degli aggiornamenti di beryl.. posso aggiornare o rischio di sfasciare tutto?? grazie.. ciao

  10. dipende dalla versione che stai usando. Se quella dei repo è successiva fai bene ad aggiornare. Io sto usando quella e funziona benissimo. :D
    Quella dei repo è la 2.1; la tua la puoi conoscere dando nel terminale:
    beryl --version

  11. beryl-core 0.2.0

    ho letto su una guida che i repo ufficiali non sono compatibili con fglrx ..
    posso eventualmente tornare indietro se l’aggiornamento non và?

  12. Sì, certo. Lo potrai disinstallare e rimettere quello che usi ora.

    ho letto su una guida che i repo ufficiali non sono compatibili con fglrx ..

    Mi pare una panzana… :) Che guida è?

  13. Now test your login. Logout, click sessions and chose GNOME with XGL. If you get to the desktop you’re now very close. If you have the universe repository enabled we need to disable it. The beryl that is in the universe does not work with xgl.

    se non dovesse funzionare quale guida devo seguire? su edgy avevo aiglx+beryl ed era molto leggero, adesso che ho xgl+beryl noto una certa pesantezza. funziona aiglx su feisty con fglrx e beryl? tnx

  14. Oggi sono riuscito a far girare gli effetti desktop con i driver fglrx (proprietari); come?…utilizzando il server grafico Xgl (Aiglx non è supportato dai driver proprietari).

  15. La tua ati funziona benissimo con i driver open (li trovi nel pacchetto xserver-xorg-video-ati) + Aiglx + Beryl (o Compiz, se preferisci).
    Il che significa che devi disinstallare quelli fglrx (proprietari). Qui e soprattutto qui dico come fare.

    Comunque, sulla mia ati (Radeon 9800SE AIW) giravano meglio i driver proprietari con Xgl+Beryl; questo non vuol dire che da te sia così.

  16. Ciao a tutti, e ciao Aldo…
    Ho un alcuni quesiti da proporvi:
    1.Ho aggiornato via rete da edgy a feisty e volevo sapere se secondo voi devo reinstallare il driver della mia scheda Ati Mobility Radeon 9700 anche se funziona bene…
    2. Quando avvio la sessione Xgl per utilizzare Beryl tutte le scritte delle icone, menu e quant’altro mi appaiono molto piccole, si fa quasi fatica a leggerle…come posso fare?

    Ciao a tutti e grazie anticipate.

  17. Premesso che quando usavo la Ati non ho avuto questo problema (e dunque non posso verificare la soluzione), proverei ad andare su Sistema / Preferenze / Tipi di carattere e lì ingrandire i corpi.

    [edit]
    Non è necessario alcun intervento per i driver.

  18. Ciao Aldo, ho provato molte volte ad installare beryl su ubuntu feisty, ma niente da fare.Mi da sampre il solito errore al login della sessione XGL:mi dice che sessione e’ durata meno di 10 secondi e se voglio “loggarmi” devo farlo con una sessione gmome.
    Utilizzo i driver con restrizioni che mi ha fatto scarica il sistema, con una ATI Mobility X1600. Come posso fare per risolvere il problema?

    Ciao a tutti.

  19. @ Domenico
    posso dirti che con la mia Ati usavo i driver fglrx scaricati dal sito ati e con Xgl funzionava molto bene. Posso solo consigliarti di installare quelli (vedi la mia guida) e, se non va ancora, di provare i pacchetti beryl di telperion.

    Prima di procedere, però, togli eventuali programmi che partono automaticamente all’avvio (tipo Skype o simili)

  20. Ok ma esiste un modo per aumentare i caratteri nella sezione Xgl tipo qualche script? io ho kubuntu, dove trovo “Sistema / Preferenze / Tipi di carattere” per provare ad aumentare i caratteri?

  21. scusate ragazzi, ma come si visualizza il cubo sul desktop? io ho un unico cubo grande che ruota con la rotellina del mouse, ma mi mostra solo una faccia a pieno schermo alla volta, ciao e grazie

  22. @ anna
    Tieni cliccata la rotellina e muovi il mouse su un punto della scrivania.
    Oppure tieni premuti Ctrl+Alt e poi muovi il mouse tenendo cliccato il tasto sinistro.

  23. funziona, grazie aldo, ma esiste un modo per lasciare fisso quel cubo rimpicciolito in mezzo al desktop? ciao e grazie ancora, anna

  24. ciao,
    ho fatto da poco l’upgrade installando feisty (un po’ in ritardo). poi ho reinstallato i driver proprietari ATI + XGL + beryl. funziona tutto e mi sembra che l’accelerazione grafica sia molto più fluida. comunque…se termino la sessione e rientro non funziona più nulla: sulle finestre si vedono righe orizzontali e non si legge il testo, rientrando con GNOME poi noto che mi saltano driver ATI (sempre dopo aver fatto ‘Termina Sessione’), ma almeno funziona tutto.
    altra cosa: se invece esco dalla sessione con ‘CONTROL+ALT+BACKSPACE’ il problema non si verifica.
    cosa può essere?
    grazie

  25. ciaoooo, come cavolo siete riusciti ha mettere baryl dopo che inserisco il codice mi dice che non trova baryl ecc… io ho la versione di lunux ubuntu 7.10 x386 cosa faccio rispondetemi per favore non so cosa fare. CIAO

  26. ciao Federico,
    hai scritto già tre richieste… calma! :D

    In Ubuntu 7.10 c’è già Compiz che basta attivare dal menu Sistema / Preferenze / Aspetto.
    Che scheda video hai?

  27. 1. Hai provato Compiz che trovi già installato in Gutsy?
    2. Se Compiz non parte, prova con Beryl, che non trovi nei repo di Gutsy (c’era in quelli di Feisty). I pacchetti per installare Beryl puoi trovarli qua: http://telperion.wordpress.com/2007/11/12/beryl-pacchetti-deb-i386-ubuntu-kubuntu-gutsy/
    2. Visto che hai una Ati, che driver stai usando? Quelli originali inclusi nella installazione di Gutsy? Allora dovresti già avere AIGLX attivo. Se hai ancora problemi, prova quelli ufficiali Ati (www.ati.com)

I commenti sono chiusi